Fruktova Gazaryan
?>

Решить задачу с линейным массивом. Составить программу, позволяющую в одномерном массиве вычислить количество элементов массива, не принадлежащих интервалу (a, b (на языке С#)

Информатика

Ответы

victoriadan
// PascalABC.Net 3.0, сборка 1066
const
  s1='АБВГабвг';
  s2='12341234';
var
  c:char;
  i:integer;
begin
  Write('Введите букву класса: '); Readln(c);
  i:=Pos(c,s1);
  if i>0 then begin
    c:=s2[i];
    case c of
    '1':Writeln('гимназический');
    '2':Writeln('математический');
    '3':Writeln('обычный');
    '4':Writeln('коррекционный')
    end
  end
  else Writeln('Неверная буква')
end.

Тестовое решение:
Введите букву класса: Б
математический

Примечание: работа программы также проверена в Borland Pascal 7.01
Giurievna1977
Uses GraphABC; 
procedure Draw(x, y, l, u : Real; t : Integer);

procedure Draw2(Var x, y: Real; l, u : Real; t : Integer);
begin
Draw(x, y, l, u, t);
x := x + l*cos(u);
y := y - l*sin(u);end; 
begin
if t > 0 then
beginl := l/3;Draw2(x, y, l, u, t-1);Draw2(x, y, l, u+pi/3, t-1);
Draw2(x, y, l, u-pi/3, t-1);Draw2(x, y, l, u, t-1);end
else
Line(Round(x), Round(y), Round(x+cos(u)*l), Round(y-sin(u)*l))end;
begin
SetWindowSize(425,500);
SetWindowCaption('Фракталы: Снежинка Коха');
Draw(10, 354, 400, pi/3, 4);Draw(410, 354, 400, pi, 4);
Draw(210, 8, 400, -pi/3, 4);end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить задачу с линейным массивом. Составить программу, позволяющую в одномерном массиве вычислить количество элементов массива, не принадлежащих интервалу (a, b (на языке С#)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Sergei1805
selena77
msk27
Елена_Зайкин1665
Инна_Nina1182
Abespal
Yurevich-Vladimirovich
Анатольевна
Vuka91
Immortal3331
koldunovan
Kharkina1328
mariokhab
Сергей_Крутикова114
sergei641