Nikita
?>

Написать программу(в паскале), которая вычисляет данное выражение: x+x³/3+x⁵/5 √ x+1-√ x-1√ x+1-√ x-1 Если будет выполняться условие, при котором данное выражение не имеет смысла, то в ответе должно выводиться «нет решений»

Информатика

Ответы

innaterenina

готово. PascalABC

Объяснение:

program tri_chisla;

var n1, n2, n3: real;

begin

 WriteLn('Ввод трех чисел и расположение их в убывающем порядке с заменой значений.');

 Write('Введите значения n1, n2 и n3 через пробел >>> ');

 ReadLn(n1, n2, n3);

 if n1 < n2 then Swap(n1, n2);

 if n2 < n3 then Swap(n2, n3);

 if n1 < n2 then Swap(n1, n2);

 WriteLn('n1=',n1,' n2=',n2,' n3=',n3);

end.

program func_L;

var

 l: real;

 x, y, z: integer;

begin

 repeat

   WriteLn('Введите значения x, y и z');

   Write('Условие: (x-y-z) должно быть больше 0 >>');

   ReadLn(x, y, z);

 until (x - y - z) > 0;

 l := x * y * z - ((abs(x)+abs(y)+abs(z))/(2 * sqrt(x - y - z)));

 WriteLn('L = ', l);

end.

program chislo_a;

var

  a: integer;

begin

 Write('Введите число a >> ');

 ReadLn(a);

 if a >= 0 then WriteLn('Больше или равно нулю')

 else WriteLn('Меньше нуля');

end.


Написать программу в паскаль и Нарисовать Блок - Схему Даю 30б
Написать программу в паскаль и Нарисовать Блок - Схему Даю 30б
Написать программу в паскаль и Нарисовать Блок - Схему Даю 30б
mikchaylovaalex

2 000 Кбайт

Объяснение:

V = t * f * i * k, где  

V - информационный объём аудио файла (размер файла, содержащего запись звука)

t - общая длительность звучания (секунды)

f - частота дискретизации (Гц, количество значений амплитуды звука, фиксируемых за одну секунду)

i - глубина звука (разрешение) (число бит, используемых для хранения каждого измеренного значения)

k -  количество каналов записи (1 - моно, 2 - стерео и т.д.)

Дано:

t = 16 сек

i = 16 бит

f = 32 кГц = 32 000 Гц

k = 2

Найти:

V

V = 16 * 32 000 * 16 * 2 = 16 384 000 бит = 2 048 000 байт = 2 000 Кбайт

1 байт = 8 бит

1 Кбайт = 1024 байт

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу(в паскале), которая вычисляет данное выражение: x+x³/3+x⁵/5 √ x+1-√ x-1√ x+1-√ x-1 Если будет выполняться условие, при котором данное выражение не имеет смысла, то в ответе должно выводиться «нет решений»
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Golovinskii_Sirotkina1944
ibombenkova
Nasteona1994
lukur2005
asi19776
Anna572
Наталья_Васищев
Алғашқы программалаушы кім???​
arhangel1055
h777eta
arnika-ooo1
det-skazka55
Васильев1028
misie1974
pronikov90
Bologova Golovach1989