Дана последовательность целых чисел написать программу которая должна выяснить является ли эта последовательность убывающей используйте паскаль, если можно, то с командой array
then writeln('последовательность не является убывающей.')
else writeln('последовательность убывающая.');
end.
программа написана на языке pascalabc.net
fedoseevalyubov
24.07.2020
1. структура для хранения и обработки данных объект - учащийся. каждый учащийся характеризуется фамилией с инициалами и имеет набор из четырех отметок по результатам сдачи экзаменов - всего 5 параметров. для простоты считаем, что фамилии с инициалами уникальны. объекты однородны, т.е. отличаются друг от друга только значениями параметров. это позволяет объединить их в группу, осуществляя доступ к каждому объекту либо по его порядковому номеру в группе, либо по фамилии. поставленная не требует поиска конкретного учащегося по фамилии, поэтому достаточно предоставлять доступ к каждому учащемуся по порядковому номеру. объект "учащийся" может быть представлен в виде записи (структуры) для случая реализации программы на алгоритмическом языке, либо в виде таблицы базы данных для случая реализации в среде субд. не исключена также примитивная реализация в виде двух массивов, в одном из которых указываются фамилии с инициалами, а в другом отметки; связь учащегося с его оценками в этом случае поддерживается за счет использования одинакового номера строк в массиве. нам также понадобится где-то хранить средний учащегося, для того чтобы сделать необходимую по условию выборку. запишем пример реализации для языка паскаль. а) три массива. var fio: array[1..40] of string; { для фамилий и инициалов } resball: array[1..40,1..4] of byte; { для оценок } srball: array[1..40] of real; { для среднего } в этом случае объект "учащийся" отображается связкой fio[i], resball[i,j], srball[i] где i- номер учащегося, j - номер отметки в наборе отметок. б) запись type tuch=record fio: string; resball: array[1..4] of byte; srball: real end; var uch: array[1..40] of tuch; в этом случае доступ к объекту "учащийся" реализуется в виде uch[i].fio, uch[i].resball[j], uch[i].srball в) таблица базы данных с именем uch fio символьный(20) ball1 целый ball2 целый ball3 целый ball4 целый srball числовой в этом случае доступ к объекту "учащийся" реализуется в виде uch.fio, uch.ball1..uch.ball4, uch.srball 2. алгоритм обработки запрашиваем n - количество учащихся в группе, и организуем ввод данных по n учащимся. попутно со вводом для каждого учащегося вычисляем сумму всех четырех его оценок, а также средний , равный найденной сумме, деленной на 4. сумму отметок по всей группе накапливаем в некоторой переменной s, а средний записываем в структуру хранения. после накопления в s суммы всех оценок находим sg=s/n - средний по группе. организуем проход по всех группе и выводим фамилию и средний тех учащихся, у которых средний превышает sg.
donertime8
24.07.2020
Понятие системы счисления для записи информации о количестве . числа записываются с использованием особых знаковых систем, которые называются системами счисления. алфавит систем счисления состоит из символов, которые называются цифрами. например, в десятичной системе счисления числа записываются с десяти всем хорошо известных цифр: 0, 1, 2, 3, 4, 5, 6, 7, 8, 9. система счисления — это знаковая система, в которой числа записываются по определенным правилам с символов некоторого алфавита, называемых цифрами. все системы счисления делятся на две большие группы: позиционные и непозиционные системы счисления. в позиционных системах счисления значение цифры зависит от ее положения в числе, а в непозиционных — не зависит.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Дана последовательность целых чисел написать программу которая должна выяснить является ли эта последовательность убывающей используйте паскаль, если можно, то с командой array
program raf105;
var a: array[1..100] of integer;
i,b: integer;
begin
writeln('вводите числа по очереди');
writeln('чтобы закончить введите 0');
i: =1;
readln(a[i]);
while a[i]< > 0 do
begin
i: = i+1;
readln(a[i]);
if a[i]> =a[i-1]
then b: =1;
end;
if b=1
then writeln('последовательность не является убывающей.')
else writeln('последовательность убывающая.');
end.
программа написана на языке pascalabc.net