okykovtun31
?>

Написать программу, без использовая sweat, через if которая задавая вопросы, ответы на которые можно получить только из множества {«Да», «Нет»} должна угадать загаданную игроком карту. Можно отрывок кода, где проверяются только несколько карт, а не все,

Информатика

Ответы

Евгеньевна_Хусинов

 1 Задание

//Ищет количество четных цифр с диапазоне от 0 до 100, 25 чисел                                            

Program v1;

var a:array[1..25]of integer;            

i,kol:integer;

begin

 kol:=0;            

randomize;

for i:=1 to 25 do a[i]:=random(100)+0;                            

write('Значение матрицы: ');                                      

for i:=1 to 25 do write(a[i]:5); writeln;                          

      for i:=1 to 25 do if a[i] mod 2=0 then kol:=kol+1;

      if kol>0 then

      writeln('Количество четных цифр: ',kol) else

        writeln('Четных элементов нет');

      end.

2 задание

      //Ищет количество  элементов матрицы кратных 3 и произведение жлементов матрицы меньше 35 в диапазоне от 50 до 10, 10 чисел                                                    

Program v1;

var a:array[1..10]of integer;            

i,sum,p:integer;

begin

 sum:=0;  

 p:=1;

randomize;

for i:=1 to 10 do a[i]:=random(40)+10;                            

write('Значение матрицы: ');                                      

for i:=1 to 10 do write(a[i]:5); writeln;                          

      for i:=1 to 10 do begin if a[i] mod 3=0 then sum:=sum+a[i];

      if a[i]<35 then p:=p*a[i]

      end;

      if sum>0 then

      writeln('Сумма элементов матрицы кратных 3: ', sum ,' ','Произведение элементов матрицы меньше 35: ',p) else

        writeln('Элементов кратных 3 нет');

      end.


с информатикой! 1. Заполните массив из 25 целых чисел случайными числами в диапазоне [0,100) и подсч
с информатикой! 1. Заполните массив из 25 целых чисел случайными числами в диапазоне [0,100) и подсч

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, без использовая sweat, через if которая задавая вопросы, ответы на которые можно получить только из множества {«Да», «Нет»} должна угадать загаданную игроком карту. Можно отрывок кода, где проверяются только несколько карт, а не все,
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

karpov68
Bogataya Vladimir318
klimovala2
fedchenkoofficial
Вершинина1161
Игорь Андрей
asemchenko
Vyacheslavovich-Gubanov
inj-anastasia8
andyrvo
Sergeevich-Novikov
dmitriy
tshelokova
starabanov
vladimirkirv