cafegasoil
?>

Напишите программу на Паскале с операторами mod и div. Дано трехзначное число. Определить кратна ли сумма его цифр числу а.​

Информатика

Ответы

myxa120283

program amountnumbers;

var

 amount, number, a: integer;

begin

 write('Введите трехзначное число: ');

 read(number);

 writeln('Введите число А:');

 read(a);

 while number > 0 do

 begin

   amount := amount + number mod 10;

   number := number div 10;

 end;

 if (amount mod a = 0) then

   writeln('Да')

 else

   writeln('Нет');

end.

Объяснение:

program amountnumbers;  // Название программы

var

 amount, number, a: integer;  // Целочисленные переменные:

amount - сумма цифр трехзначного числа;number - трехзначное число, вводимое с клавиатуры;a - число для проверки на кратность.

begin  // Начало программы

 write('Введите трехзначное число: ');  // Вывод сообщения в консоль

 read(number);  // Считываем трехзначное число с клавиатуры

 writeln('Введите число А:');  // Вывод сообщения в консоль

 read(a);  // Считываем число А с клавиатуры

 while number > 0 do  // Пока значение переменной number > 0

 begin  // Начало цикла

   amount := amount + number mod 10;  // Сумма цифр = сумма цифр + последняя цифра числа

   number := number div 10;  // Отделяем последнюю цифру от числа

 end;  // Конец  цикла

 if (amount mod a = 0) then  // Если значение переменной amount делится на значение переменной A без остатка, тогда

   writeln('Да')  // Вывод сообщения в консоль

 else  // Иначе

   writeln('Нет');  // Вывод сообщения в консоль

end. // Конец программы

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на Паскале с операторами mod и div. Дано трехзначное число. Определить кратна ли сумма его цифр числу а.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vasearu
lanabogd
makitra08
arutchevben64
denspiel
mishapavlov9
marketing3
kiparistop
david-arustamyan1
sychevao19975
sashakrav
manimen345
Герасименко
Давид-Ольга
askorikova