Поделитесь своими знаниями, ответьте на вопрос:
2 задачи. решите любую 1.Даны три целых числа A, B, C, значения которых вводятся с клавиатуры. Написать программу, которая выводит на экран · TRUE, если хотя бы одно из чисел A, B, C отрицательно; · FALSE в противном случае Оператор if then else не использовать 2. Заданы радиус круга, сторона квадрата, две смежные стороны прямоугольника и три стороны треугольника. Определить, какая фигура имеет большую площадь.
Внимание! Хром жрет строки! Сейчас поправлю
Laboratorna2.cs
//////////////////////////////////////////////////
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
namespace Laboratorna2{
class Laboratorna2
{
public static void A() {
Console.WriteLine("Привет, это метод А()");
}
public static void B(int n, int m) {
Console.WriteLine(n + m);
Console.WriteLine(n - m);
Console.WriteLine(n * m);
Console.WriteLine(Convert.ToDouble(n) / m);
}
public static double C(double k, double l, double m) {
return (k + l + m) / 3;
}
public static string N11(ref int Numb) {
Numb = 11 * Numb; return "";
}
public static int Line(ref string line) {
char[] arr = line.ToCharArray();
Array.Reverse(arr);
line = new string(arr);
return line.Length;
}
static void Main(string[] args) {
Console.WriteLine("Метод А:"); A();
Console.WriteLine("Метод B:"); B(5, 7);
Console.WriteLine("Метод C: {0}", C(4.33, 13.6, -14.88439435));
Console.WriteLine("Geometry.S: {0}", Geometry.S(5));
double P, S;
Geometry.Par(5, out P, out S);
Console.WriteLine("Geometry.Par: P={0}; S={1}", P, S);
int N = 7;
Console.WriteLine("Метод N11: Число = {0}; Результат = {2}", N, N11(ref N), N);
string kekus = "Lol Kek Cheburek!";
Console.WriteLine("Метод Line: Исходная строка = \"{0}\"; Длина = {1}; Результирующая строка = \"{2}\";", kekus, Line(ref kekus), kekus);
Console.ReadKey();
}
}
}
Geometry.cs
\\\\\\\\\\\\\\\\\\\\\\\\\
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
namespace Laboratorna2 {
class Geometry {
public static double S(double R) {
return Math.PI * Math.Pow(R, 2);
}
public static void Par(double R, out double S, out double P) {
S = Math.PI * Math.Pow(R, 2);
P = 2 * Math.PI * R;
}
}
}