Wlad967857
?>

Написать программу: Вводятся координаты четырёх точек на плоскости, определить могут ли они быть вершинами выпуклого четырёхугольника.

Информатика

Ответы

Хабарьева Андрей1056
{ ответ дан на языке Pascal }
{         Вариант a         }
PROGRAM Solution(INPUT, OUTPUT);

VAR
  Str: STRING;
  Str1: STRING;
  Str2: STRING;
  Str3: STRING;
  TempStr: STRING;

BEGIN
  WRITE('Введите строку: ');
  READLN(Str);
  Str1 := COPY(Str, 1, LENGTH(STR) DIV 3);
  Str2 := COPY(Str, LENGTH(STR) DIV 3 + 1, (LENGTH(STR) DIV 3));
  Str3 := COPY(Str, (LENGTH(STR) DIV 3) * 2 + 1, LENGTH(STR));

  WRITELN(Str2 + Str3 + Str1);

END.

{         Вариант b         }
PROGRAM Solution(INPUT, OUTPUT);

VAR
  Str: STRING;
  Str1: STRING;
  Str2: STRING;
  Str3: STRING;
  TempStr: STRING;

BEGIN
  WRITE('Введите строку: ');
  READLN(Str);
  Str1 := COPY(Str, 1, LENGTH(STR) DIV 3);
  Str2 := COPY(Str, LENGTH(STR) DIV 3 + 1, (LENGTH(STR) DIV 3));
  Str3 := COPY(Str, (LENGTH(STR) DIV 3) * 2 + 1, LENGTH(STR));

  WRITELN(Str3 + Str1 + Str2);

END.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу: Вводятся координаты четырёх точек на плоскости, определить могут ли они быть вершинами выпуклого четырёхугольника.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

VladimirovnaSimonov
orange-salon-job77
happygal5224
Сергей
Vladimirovna
pryvalovo48
julya847
ALLA1868
МуратМарина1140
Смирнов_Андрей691
scraer198258
yusovd291
Chistov9721209
Dmitrievna405