?>
С клавиатуры вводится строка состоящая из предложений разделяемых точками.Составьте программу выполняющую следующие форматирования:первое слово в предложении должно начинаться с прописной буквы, после каждой точки должен стоять один пробел. Обычный PascalABC.NET
Ответы
var
s: string;
i, n: byte;
begin
writeln('введите строку ');
readln(s);
s[1]:=upcase(s[1]);
for i:=length(s) downto 1 do
if s[i]='.' then
begin
if s[i+1]<>' 'then
begin
s[i+1]:=upcase(s[i+1]);
insert(' ',s,i+1);
end
else
for n:=i+1 to length(s)do
if s[n]<>' 'then
begin
s[n]:=upcase(s[n]);
end;
end;
begin
writeln(s);
end;
end.
Объяснение: