ale-protasov
?>

Напишите программу , которая печатает в убывающем порядке квадраты всех натуральных чисел от 1 до 60 включительно , делящихся без остатка 7. на паскале

Информатика

Ответы

dmdlir
Var
  A: array [1..120] of real;
  i, res: integer;

begin
  randomize();
  res := 0;
 
  for i := 1 to 120 do
  begin
    A[i] := random(101);
    writeln('A[', i, '] => ', A[i]);
  end;
  writeln();
 
  for i := 1 to 120 do
    if abs(A[i]) > 17 then
      inc(res);
 
  writeln(res);
end.



var
  C: array [1..20] of integer;
  i, res: integer;

begin
  randomize();
  res := 0;
 
  for i := 1 to 20 do
  begin
    C[i] := random(101);
    writeln('C[', i, '] => ', C[i]);
  end;
  writeln();
 
  for i := 1 to 20 do
    if C[i] mod 2 = 1 then
      C[i] := -1 * C[i];
 
  writeln('New array:');
  for i := 1 to 20 do
  begin
    writeln('C[', i, '] => ', C[i]);
  end;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу , которая печатает в убывающем порядке квадраты всех натуральных чисел от 1 до 60 включительно , делящихся без остатка 7. на паскале
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

СмыковаДарья1969
mariashapar
Peshkov
myhauz
sryzhova6392
denbelousov963
Яковчук1911
Татьяна1856
snopovajulia
Полковников_Милана
rkorneev19061
keti0290103
fialkaflowers77
Alekseevich1012
milanparipovic864