?>
В программе Pascal ABC решите следующие задачи 2.Циклически сдвиньте элементы списка вправо (A[0] переходит на место A[1], A[1] на место A[2], ..., последний элемент переходит на место A[0] Используйте минимально возможное количество операций присваивания. Входные данные Вводится список чисел. Все числа списка находятся на одной строке. Выходные данные Выведите ответ на задачу.
Ответы
begin
var k:=0;
var Terminate:boolean;
repeat
Terminate:=True;
var n:=ReadInteger('Введите номер месяца:');
case n of
1,3,5,7,8,10,12:Writeln('31 день');
4,6,9,11:Writeln('30 дней');
2:Writeln('28 дней в обычном году и 29- в високосном')
else begin
Writeln('Вы ошиблись, номер должен быть от 1 до 12');
Inc(k);
Terminate:=False
end
end
until Terminate;
if k>0 then Writeln('Вы ошиблись ',k,' раз(а).')
end.
Тестовое решение:
Введите номер месяца: 18
Вы ошиблись, номер должен быть от 1 до 12
Введите номер месяца: 0
Вы ошиблись, номер должен быть от 1 до 12
Введите номер месяца: 5
31 день
Вы ошиблись 2 раз(а).