Язык программирования Pascal ABC var n,k,i,j,d,c:integer; label 1,2; begin 1:writeln('Количество месяцев в календаре планеты Мульти:'); readln(n); if (n>109)or(n<1) then begin writeln('Ошибка! Количество месяцев должно быть меньше или равно 109. Повторите ввод.'); goto 1; end; 2:writeln('Номер дня на который приходится первое число первого месяца нового года:'); readln(k); if (k>7)or(k<1) then begin writeln('Ошибка! Номер дня должен быть в диапозоне от 1 до 7. Повторите ввод.'); goto 2; end; d:=k; for i:=1 to n do begin for j:=1+(k-1) to 30 do begin if (d=5)and(j=13) then c:=c+1; d:=d+1; if d>7 then d:=1; end; k:=1; end; writeln('Количество несчастливых дней в этом году: ',c); end.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу, которая вычисляет значения функции y=x+4х, где x (-3;10) с шагом 0, 2 Информатика
var n,k,i,j,d,c:integer;
label 1,2;
begin
1:writeln('Количество месяцев в календаре планеты Мульти:');
readln(n);
if (n>109)or(n<1) then
begin
writeln('Ошибка! Количество месяцев должно быть меньше или равно 109. Повторите ввод.');
goto 1;
end;
2:writeln('Номер дня на который приходится первое число первого месяца нового года:');
readln(k);
if (k>7)or(k<1) then
begin
writeln('Ошибка! Номер дня должен быть в диапозоне от 1 до 7. Повторите ввод.');
goto 2;
end;
d:=k;
for i:=1 to n do
begin
for j:=1+(k-1) to 30 do
begin
if (d=5)and(j=13) then c:=c+1;
d:=d+1;
if d>7 then d:=1;
end;
k:=1;
end;
writeln('Количество несчастливых дней в этом году: ',c);
end.