?>
с информатикой от 1. Определите значение переменной «a» после выполнения фрагмента программы: a := 7; if a < 10 then a := a + 10 else a := a - 17;2. Сколько раз исполнится цикл:for k := 3 to 9 do3. Запишите значение переменной s, полученное в результате работы следующей программы.а)var s, k: integer; begin s := 0; for k := 2 to 7 do s := s + 4; writeln(s); end.б)var s, k: integer; begin s := 60; for k := 0 to 3 do s := s − 8; writeln(s); end.в)var y, i: integer; begin y := 0; for i := 1 to 4 do y := y + 2 * i; writeln(y); end.
Ответы
Объяснение:
Задание №1
1. После присваивания значение переменной а согласно первому условию увеличится на 12 так как 10>5. Значит переменная а будет равна 22
2. Второе условие аналогично первому, значит переменная а еще раз увеличится на 12
ответ для задания №1: а = 34
Задание №2
1. После выполнения первого условия переиенная а не изменится, а переменная b увеличится на 12 и станет равна 15
2. После выполнения второго условия переменная а уменьшится на 7 так как 10<15.
ответ к заданию №2: a = 3