utkinslava
?>

Язык Python. Напишите программу, которая будет выводить, какую по счёту дощечку прибили.Формат вводаСначала вводится число – сколько нужно дощечек.Затем вводятся строки, пока не будет введена строка КОНЕЦФормат выводаСтроки, в которых нет слова доска или дощечка, игнорируются. Если хотя бы одно из слов есть, то выводим:Прибили {номер} дощечку.Как только все прибили, на дальнейший ввод не обращаем внимание и выводим:ГОТОВОЕсли не хватило, то вывести в конце:МАЛОВАТО​

Информатика

Ответы

zamkova836

x = int(input())

s = ''

c = 0

while s != 'КОНЕЦ':

   s = input()

   if 'доска' in s or 'дощечка' in s:

       c += 1

       print('Прибили', c, 'дощечку.')

   if c == x:

       break

if c != x:

   print('МАЛОВАТО')

else:

   print('ГОТОВО')

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Язык Python. Напишите программу, которая будет выводить, какую по счёту дощечку прибили.Формат вводаСначала вводится число – сколько нужно дощечек.Затем вводятся строки, пока не будет введена строка КОНЕЦФормат выводаСтроки, в которых нет слова доска или дощечка, игнорируются. Если хотя бы одно из слов есть, то выводим:Прибили {номер} дощечку.Как только все прибили, на дальнейший ввод не обращаем внимание и выводим:ГОТОВОЕсли не хватило, то вывести в конце:МАЛОВАТО​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

dimaproh
rusinfopro
aaltuxova16
d43irina
Lomakina-Valerievna1779
Asdfdsafsdfgdfshhsdfdfghdffdsa
AkimovaI1608
evsmorodina
Косоногов Иосифовна
Andrei_Mariya
vera-spicina
Шаленко
stic1995
aerendzhenova5
NikolaevichIP1136
Boris1247