nikolai37
?>

Многогласные слова Назовем слово многогласным, если гласных букв в нем больше, чем согласных. Гласными буквами будем считать буквы «a», «e», «i», «o» и «u». Напишите программу, которая для данного слова S определяет, является ли оно многогласным. Формат ввода: В единственной строке вводится слово S, состоящее из строчных латинских букв. Длина строки S не превышает 100 символов. Формат вывода: Выведите «Yes» (без кавычек), если число является многогласным и «No» в противном случае. Слова «Yes» и «No» допускается выводить в любом регистре. Пример 1 Ввод Вывод be No Пример 2 Ввод Вывод bee Yes Пример 3 Ввод Вывод bb No Пример 4 Ввод Вывод australia Yes

Информатика

Ответы

drevile57

это всего на но вот

Объяснение:

s=str(input())

a=len(s)

b=len(s)

glas=0

soglas=0

while a>0:

   for i in range(0,b):

       if s[i]==('a') or s[i]==('e') or s[i]==('i') or s[i]==('o') or s[i]==('u') or s[i]==('y')or s[i]==('A') or s[i]==('E') or s[i]==('I') or s[i]==('O') or s[i]==('U') or s[i]==('Y'):

           glas=glas+1

       else:

           soglas=soglas+1

   a=a-1

if glas>soglas:

   print('Yes')

elif glas<=soglas:

   print('No')

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Многогласные слова Назовем слово многогласным, если гласных букв в нем больше, чем согласных. Гласными буквами будем считать буквы «a», «e», «i», «o» и «u». Напишите программу, которая для данного слова S определяет, является ли оно многогласным. Формат ввода: В единственной строке вводится слово S, состоящее из строчных латинских букв. Длина строки S не превышает 100 символов. Формат вывода: Выведите «Yes» (без кавычек), если число является многогласным и «No» в противном случае. Слова «Yes» и «No» допускается выводить в любом регистре. Пример 1 Ввод Вывод be No Пример 2 Ввод Вывод bee Yes Пример 3 Ввод Вывод bb No Пример 4 Ввод Вывод australia Yes
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

gorushko-tabak3
dearmaria
Барскова1943
profitgroup51
nzaripova313
patersimon1
potemkin77
Алексей Шуклин
Юрий197
fominovaVladislav1346
Naumenkova-Ivanov
roman-fetisov2005
Georgievich-Zamudinovna2003
Galinagol559
ev27076878