Запишите цикл, с которого можно вывести на экран A)целые числа от a до b (a < b) Б)квадраты целых чисел от a до b (a < b) написать программу надо на Pascal
writeln('Сумма положительных элементов массива равна ', s)
end.
2)var
a:array[1..10]of integer;
i,n,P:integer;
begin
writeln('Введите число элементов');
readln(n);
writeln('Введите число');
P:=1;
for i:=1 to n do begin
read(a[i]);
if a[i] mod 6 = 0
then P:=P*a[i]
end;
writeln('Произведение элементов массива кратных 6 равна ',P)
end.
3)var
a:array[1..5]of integer;
n,i:integer;
begin
writeln('Введите кол-во элементов');
readln(n);
writeln('Введите число');
for i:=1 to n do begin
read(a[i]);
if a[i]>0 then begin
a[i]:=a[i]*3;
writeln('Новый элемент равен: ',a[i])
end;
if a[i]<=0 then begin
a[i]:=a[i]+5;
writeln('Новый элемент равен: ',a[i])
end;
end;
end.
Буду рад если отметишь мой ответ как лучший
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Запишите цикл, с которого можно вывести на экран A)целые числа от a до b (a < b) Б)квадраты целых чисел от a до b (a < b) написать программу надо на Pascal
1)var
a:array[1..5]of integer;
i,n,s:integer;
begin
writeln('Введите кол-во элементов');
readln(n);
writeln('Введите число');
s:=0;
for i:=1 to n do begin
read(a[i]);
if a[i]>0 then s:=s+a[i]
end;
writeln('Сумма положительных элементов массива равна ', s)
end.
2)var
a:array[1..10]of integer;
i,n,P:integer;
begin
writeln('Введите число элементов');
readln(n);
writeln('Введите число');
P:=1;
for i:=1 to n do begin
read(a[i]);
if a[i] mod 6 = 0
then P:=P*a[i]
end;
writeln('Произведение элементов массива кратных 6 равна ',P)
end.
3)var
a:array[1..5]of integer;
n,i:integer;
begin
writeln('Введите кол-во элементов');
readln(n);
writeln('Введите число');
for i:=1 to n do begin
read(a[i]);
if a[i]>0 then begin
a[i]:=a[i]*3;
writeln('Новый элемент равен: ',a[i])
end;
if a[i]<=0 then begin
a[i]:=a[i]+5;
writeln('Новый элемент равен: ',a[i])
end;
end;
end.
Буду рад если отметишь мой ответ как лучший