Bezzubova_Stepanov1355
?>

Напишите программу, которая оценит справедливость конспирологического тарифа. Из списка чисел нужно выбрать те, что имеют ту же чётность, что и минимальное. Формат ввода Вводится строка целых чисел, записанных через пробел. Формат вывода Вывести числа, которые имеют ту же чётность, что и наименьшее, без повторений, порядок вывода неважен. Пример 1 Ввод 2 5 17 3 18 6 1 9 Вывод 1 3 5 9 17

Информатика

Ответы

Olegovich Nikolaevna

a = list(map(int, input().split()))

m = min(a)

res = []

for i in range(len(a)):

   if(a[i]%2==m%2 and a[i] not in res):

       res.append(a[i])

for row in range(len(res)):

   print(res[row], end=' ')

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая оценит справедливость конспирологического тарифа. Из списка чисел нужно выбрать те, что имеют ту же чётность, что и минимальное. Формат ввода Вводится строка целых чисел, записанных через пробел. Формат вывода Вывести числа, которые имеют ту же чётность, что и наименьшее, без повторений, порядок вывода неважен. Пример 1 Ввод 2 5 17 3 18 6 1 9 Вывод 1 3 5 9 17
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

bereza81
eeirikh
fedorenkoroman
izumrud153
morozovalexander90
Valentinovna
Yurevich-Vladimirovich
artem-dom
NatalyaAlekseevich1644
djevgen
denisrogachv
gunel1988alieva
karavan85450
Serdechnaya636
Чечин-Павлова615