var a:array[1..10] of integer;
i, c: integer;
begin
for i := 1 to 10 do read(a[i]);
c := 0;
for i := 1 to 10 do
if a[i] mod 10 = 0 then c := c + 1;
writeln(c)
end.
Объяснение:
Чётные числа, кратные 5 - это числа, которые делятся на 10, поэтому проверяем делимость на 10.
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу которая в массиве из 10 целых чисел определит кол-во четных чисел, кратных 5. (Паскаль)
var a:array[1..10] of integer;
i, c: integer;
begin
for i := 1 to 10 do read(a[i]);
c := 0;
for i := 1 to 10 do
if a[i] mod 10 = 0 then c := c + 1;
writeln(c)
end.
Объяснение:
Чётные числа, кратные 5 - это числа, которые делятся на 10, поэтому проверяем делимость на 10.