Мунировна
?>

Написать программу на языке C #, которая рассчитывает значение выражения с использованием оператора for. Запрещается использовать функции класса Math. Для вариантов 1-10 сравнить рассчитанные значения выражения со значениямиполученными с проверочной функции.На фото не видно, там і=1

Информатика

Ответы

Ainura Pokhomova
Program asd;
Var A,C:array[1..2500] of integer;
i,n,s,ii:integer;
 sr:real;
BEGIN
Write('Введите n: '); Readln(n);
Writeln('Массив: ');
 For i:=1 to n do
  begin
  A[i]:=1+Random(9); 
 Write(A[i]:2); 
  end;  
 Writeln; 
 Writeln('Все элементы, которые меньше последнего числа в ряду: ');
For i:=1 to n do  
begin
 if A[i]<A[n] then Write(A[i]:2); 
end; 
Writeln;
 Writeln('Среднее арифметическое элементов массива: '); 
 For i:=1 to n do 
 begin 
 s:=s+A[i]; 
 sr:=s/i; 
end; 
Writeln(sr:2:2);  
   Writeln('Номер элементов, которые от 3 до 7.: ');  
  For i:=1 to n do 
 begin 
 If  (A[i]>=3) and (A[i]<=7)   
 then
  begin 
  C[i]:=i; 
 Write(C[i],' '); 
 end;   
 end;  
END.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке C #, которая рассчитывает значение выражения с использованием оператора for. Запрещается использовать функции класса Math. Для вариантов 1-10 сравнить рассчитанные значения выражения со значениямиполученными с проверочной функции.На фото не видно, там і=1
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

almazsit85
egcuzn86
danya1509379
jurys71242
ВадимСмирнов116
makitra08
bas7572513
nataliaprintroll
Olesyamilenina8
abdulhakovalily22
Хромов1501
denbelousov963
Konstantinovich alekseevna993
Андрей-Викторовна1910