cholga69
?>

Самостоятельная работа по программированию «ЦИКЛЫ С ПАРАМЕТРОМ» напишите программу, которая выводит на экран таблицу умножения на 7. Рекомендуемый видрана во время работы программы приведен ниже:0х7 = 01 x7 = 12х7 = 143х7 = 2110 х 7 = 70​

Информатика

Ответы

Татьяна_Вологжин
#include <iostream>
#include <string>
using namespace std;

string arabicToRoman(unsigned &number)
{
const unsigned count = 13;unsigned arabic[count] = { 1000, 900, 500, 400, 100, 90, 50, 40, 10, 9, 5, 4, 1
}, i, j;
string roman[count] = { "M", "CM", "D", "CD", "C", "XC", "L", "XL", "X", "IX",
"V", "IV", "I" }, result = "";
for (i = 0; i < count; i++) {
for (j = 0; j < number / arabic[i]; j++) {
result += roman[i];
}
number %= arabic[i];
}
return result;
}

int main()
{
unsigned uin = 0;
cin >> uin;
cout << arabicToRoman(uin);
system("pause");
return 0;
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Самостоятельная работа по программированию «ЦИКЛЫ С ПАРАМЕТРОМ» напишите программу, которая выводит на экран таблицу умножения на 7. Рекомендуемый видрана во время работы программы приведен ниже:0х7 = 01 x7 = 12х7 = 143х7 = 2110 х 7 = 70​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Оксана Анна
edvlwork15
anovikovsr
ganul
Михаил1121
praskovya17
arina2403423
Savelieva24
info9
игнатова_Сергей1228
Georgievna1407
sev-94428
seleznev1980
Akvamontaz
Paradismebel