Zashchitin Denis
?>

Знайти всі трьохзначні числа, середня цифра яких дорівнює сумі першої та останньої цифр. Надо написать программу​

Информатика

Ответы

kengyra
//PascalABC.NET (версия 3.1, сборка 1198 от 11.03.2016)
var a,n,k,i,j,s:integer;
begin
  writeln('Количество учеников и количество оценок');
  readln(n,k);
  for i:=1 to n do begin
    for j:=1 to k do begin
      write('Ученик № ',i, ' оценка № ',j,' = ');
      readln(a);
      s:=s+a;
    end;
  end;
  println('Средняя оценка группы ',s/(n*k):6:3);
end.

Тестовое решение:
Количество учеников и количество оценок
3 3
Ученик № 1 оценка № 1 = 3
Ученик № 1 оценка № 2 = 4
Ученик № 1 оценка № 3 = 4
Ученик № 2 оценка № 1 = 5
Ученик № 2 оценка № 2 = 4
Ученик № 2 оценка № 3 = 4
Ученик № 3 оценка № 1 = 4
Ученик № 3 оценка № 2 = 3
Ученик № 3 оценка № 3 = 3
Средняя оценка группы  3.778

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Знайти всі трьохзначні числа, середня цифра яких дорівнює сумі першої та останньої цифр. Надо написать программу​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ghjcnjtyjn64
elenalukanova
tiv67
Ольга
соловьев_Куркина
Лилин1079
Vladimirovich-Aleksandrovna96
mayskiyandrey90
a-zotova
svetsalikowa
Serkova_Elena251
Rustamov741
Varagyant
Николаевна Филиппов1936
d111180