Поделитесь своими знаниями, ответьте на вопрос:
Отримати на комп'ютері зі слова "інформатика" нові слова. Наприклад "форма", "мама", "формат", "рама".Вхідні дані:const d='інформатика' Надо составить программу Блок схема: початок ввести d a:copy(d, 3, 5) a b:copy(d, 6, 2)+copy (d, 6, 2) b c:copy(d, 6, 2) c k:copy (d, 5, 1)+copy(d, 7, 1)+(d, 6, 2) k
begin
var m:=ReadInteger('Количество элементов в массиве А (m):');
var n:=ReadInteger('Количество элементов в массиве B (n):');
var k:=ReadInteger('Позиция вставки k (1<k<m):');
if (k>1) and (k<m) then begin
var a:=ArrRandom(m,1,99); Writeln('Массив A'); a.Println;
var b:=ArrRandom(n,1,99); Writeln('Массив B'); b.Println;
Writeln('Результат вставки'); (a[:k]+b+a[k:]).Println
end
else Writeln('Вы нарушили условие 1<k<m')
end.
Тестовое решение
Количество элементов в массиве А (m): 10
Количество элементов в массиве B (n): 6
Позиция вставки k (1<k<m): 4
Массив A
68 64 30 75 36 15 50 39 92 26
Массив B
56 68 97 30 95 63
Результат вставки
68 64 30 75 56 68 97 30 95 63 36 15 50 39 92 26