nat63nesnova5
?>

Тест по теме «Язык программирования Паскаль» 1. Для отделения операторов друг от друга в языке Паскаль используют: а) пробел; б) двоеточие; в) запятую; г) точку с запятой. 2. Из предложенных заголовков программы правильным является: а) Program сумма; в) programm сумма; б) programm summa; г) program summa. 3. Для вывода результатов в языке программирования Паскаль используют ключевое слово: а) VAR; б) READ; в) BEGIN; г) WRITE. 4. Квадратный корень числа вычисляет функция: а) SQRT (X); б) SQR (X); в) ABS (X); г) INT (X 5. Конечное значение переменной У в результате выполнения следующих действий: У:=5; Х:=2; У:=(У-2*Х)/2+Х будет равно: а) 0, 5; б) 2; в) 2, 5; г) 5. 6. В результате выполнения программы program my_klass; begin write (25/2, 5*2); writeln (‘улыбок’); end. мы увидим на экране: а) 5 улыбок; в) 5 улыбок; б) 25 улыбок; г) 25 улыбок. 7. В данном фрагменте программы program error; begin summa:=25-14; end. ошибкой считают: а) некорректное имя программы; б) длинное имя переменной; в) не определенное имя переменной; г) запись арифметического выражения. 8. Значения одномерного массива задаются с цикла: for i:=1 to 5 do B[i]:= 5+i; В результате значение В[3] будет равно: а) 9; б) 8; в) 7; г) 6. 9. for i:=1 to 10 do begin if a[i]>0 then a[i]:=a[i]/2 else a[i]:=i; end; произойдет следующее: а) положительные значения элементов массива увеличатся вдвое, а отрицательные заменятся значениями индекса; б) положительные значения элементов массива уменьшатся вдвое, а отрицательные заменятся значениями индекса; в) отрицательные значения элементов массива увеличатся вдвое, а положительные заменятся значениями индекса; г) отрицательные значения элементов массива уменьшатся вдвое, а положительные заменятся значениями индекса. 10. В результате выполнения фрагмента программы writeln (‘Новый массив’); for i:=1 to 20 writeln (a[i]); end. произойдет следующее: а) сформируется новый массив; б) новый массив распечатается; в) распечатаются только индексы; г) сформируются только индексы.

Информатика

Ответы

Svetlana290419

Задание 1

program HelloMoney;

 var

 y, i: integer; // Объявим переменные для количества лет вклада и для счетчика цикла  

p, s: real; //Объявим переменные для количества процентов и величины вклада

begin

write('Какая сумма вклада? ');

readln(s); // Указываем сколько составляет вклад

write('На сколько лет вклад? ');

readln(y); // Указываем на сколько лет вклад

write('Какая процентная ставка?');

readln(p); // Указываем процентную ставку

for i:=1 to y do

s := s + s*p/100; // Прибавляем к вкладу ежегодный процент

write('Сумма денег составит: ', s);

end.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Тест по теме «Язык программирования Паскаль» 1. Для отделения операторов друг от друга в языке Паскаль используют: а) пробел; б) двоеточие; в) запятую; г) точку с запятой. 2. Из предложенных заголовков программы правильным является: а) Program сумма; в) programm сумма; б) programm summa; г) program summa. 3. Для вывода результатов в языке программирования Паскаль используют ключевое слово: а) VAR; б) READ; в) BEGIN; г) WRITE. 4. Квадратный корень числа вычисляет функция: а) SQRT (X); б) SQR (X); в) ABS (X); г) INT (X 5. Конечное значение переменной У в результате выполнения следующих действий: У:=5; Х:=2; У:=(У-2*Х)/2+Х будет равно: а) 0, 5; б) 2; в) 2, 5; г) 5. 6. В результате выполнения программы program my_klass; begin write (25/2, 5*2); writeln (‘улыбок’); end. мы увидим на экране: а) 5 улыбок; в) 5 улыбок; б) 25 улыбок; г) 25 улыбок. 7. В данном фрагменте программы program error; begin summa:=25-14; end. ошибкой считают: а) некорректное имя программы; б) длинное имя переменной; в) не определенное имя переменной; г) запись арифметического выражения. 8. Значения одномерного массива задаются с цикла: for i:=1 to 5 do B[i]:= 5+i; В результате значение В[3] будет равно: а) 9; б) 8; в) 7; г) 6. 9. for i:=1 to 10 do begin if a[i]>0 then a[i]:=a[i]/2 else a[i]:=i; end; произойдет следующее: а) положительные значения элементов массива увеличатся вдвое, а отрицательные заменятся значениями индекса; б) положительные значения элементов массива уменьшатся вдвое, а отрицательные заменятся значениями индекса; в) отрицательные значения элементов массива увеличатся вдвое, а положительные заменятся значениями индекса; г) отрицательные значения элементов массива уменьшатся вдвое, а положительные заменятся значениями индекса. 10. В результате выполнения фрагмента программы writeln (‘Новый массив’); for i:=1 to 20 writeln (a[i]); end. произойдет следующее: а) сформируется новый массив; б) новый массив распечатается; в) распечатаются только индексы; г) сформируются только индексы.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

gaina6678
Alex17841
derkachn6429
serkan777
Лебедев972
nairahay
cosmetic89
gena1981007
Lianchikavon
mashuska
sergei-pletenev
Olga_Vyacheslavovich1054
arhangel1055
Aleksandrovna370