poch23420
?>

Напишите, программу, которая читает натуральное число , которая печатает фразу "я люблю Школково" раз на одной строке через точку. Пример: Входные данные: 3 Выходные данные: я люблю Школково.я люблю Школково.я люблю Школково

Информатика

Ответы

dkvsadovoe
Алгоритм
Ввод массива A[n,m]
Max := A[1,1]; k := 1; p := 1; s := 0;
Алгоритм
Ввод массива A[n,m]
Max := A[1,1]; k := 1; p := 1; c := 0;
Цикл по i от 1 до n (по строкам)
Цикл по j от 1 до m (по столбцам)
Если (A(i, j) = Max) and ((i<>k) or (j<>p)) То c := c+1;
Если (A(i, j) > Max) То
k := i; p := j; c := 1;
Max: = A(i, j);
Конец Если
Конец цикла по столбцам
Конец цикла по строкам
Вывод "Элемент ", Max, " встречается ", c, " раз"
Конец.

Программа
var A: array of array of integer
var i,j,m,n,k,p,s,Max: integer
BEGIN
uses crt; clrscr;
write ('Vvedite kol-vo strok: '); readln (n);
write ('Vvedite kol-vo stolbtsov: '); readln (m);
setlength(A,n,m);
for i=1 to n do
begin
for j=1 to m do
begin
write ('Vvedite element vassiva: '); readln (A[i,j]);
end;
end;
Max := A[1,1]; k := 1; p := 1; c := 0;
for i=1 to n do
begin
for j=1 to m do
begin
if (A(i, j) = Max) and ((i<>k) or (j<>p)) then c := c+1;
if (A(i, j) > Max) then
begin
k := i; p := j; c := 1;
Max: = A(i, j);
end;
end;
end;
write ('Element ', Max, ' vstrechaetsya ', c, ' raz');
END.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите, программу, которая читает натуральное число , которая печатает фразу "я люблю Школково" раз на одной строке через точку. Пример: Входные данные: 3 Выходные данные: я люблю Школково.я люблю Школково.я люблю Школково
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ashantik
shef3009
ohussyev
VadimovichSvetlana622
sv455umarketing74
Жуков219
Валерьевна1601
Mariya-Karaseva
mishamedbrat
Alekseevich_Viktorovna
diana0720
and-syr
martinson1136
Dmitrii sergei463
olimov9