Svetlana1287
?>

Задан массив A[1, 15] случайным образом на отрезке [1, 20]. Составить программу поиска элемента, равного

Информатика

Ответы

Itina321t

язык программирования python

summ = 0

pro = 0

first = True

N = int(input('Введите N: '))

K = int(input('Введите K: '))

M = int(input('Введите M: '))

str_A = input('Введите последовательность a через пробел: ').split()

A = [int(item) for item in str_A]

for i in range(1, N + 1, 2):

   if A[i] % K != 0 and A[i] % M == 0 and first:

       first = False

       summ = A[i]

       pro = A[i]

   elif A[i] % K != 0 and A[i] % M == 0 and not(first):

       summ += A[i]

       pro *= A[i]

print('Сумма: ' + str(summ))

print('Произведение: ' + str(pro))

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задан массив A[1, 15] случайным образом на отрезке [1, 20]. Составить программу поиска элемента, равного
Ваше имя (никнейм)*
Email*
Комментарий*