Плотность, я так понимаю, населения на квадратный километр? Взял инфу из Wiki. Вот что получилось:
program HomeWork;
const countries:array[1..10] of string = ('Россия', 'США', 'Греция', 'КНР', 'Турция', 'Германия', 'Испания', 'Колумбия', 'Бразилия', 'Египет');
const density:array[1..10] of real = (8.56,32,81,650,100,230,92,39,23.6,80);
var i:integer;
var d:real;
var s:string;
begin
d := 0;
for i := 1 to length(density) do
if d < density[i] then
d := density[i];
s := countries[i];
end;
writeln('Самая большая плотность в ', s, ', и она равна ', d:3:0, ' человек на квадратный километр')
end.
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу на языке Pascal. Занесите информацию о десяти европейских странах в массивы. Найдите максимальную численность населения Вот страны:Россия, США, Греция, КНР, Турция, Германия, Испания, Колумбия, Бразилия, Египет
Плотность, я так понимаю, населения на квадратный километр? Взял инфу из Wiki. Вот что получилось:
program HomeWork;
const countries:array[1..10] of string = ('Россия', 'США', 'Греция', 'КНР', 'Турция', 'Германия', 'Испания', 'Колумбия', 'Бразилия', 'Египет');
const density:array[1..10] of real = (8.56,32,81,650,100,230,92,39,23.6,80);
var i:integer;
var d:real;
var s:string;
begin
d := 0;
for i := 1 to length(density) do
begin
if d < density[i] then
begin
d := density[i];
s := countries[i];
end;
end;
writeln('Самая большая плотность в ', s, ', и она равна ', d:3:0, ' человек на квадратный километр')
end.