Составьте программу, которая для целого числа k(от1 до 99) , введеного вами, напечатает фразу "Мне k лет", при этом в нужных случаях слово "лет" заменяя на "год" и "года" В кумире
Program k1; var a: integer; begin writeln ('Введите число От 1 до 20'); readln (a); if a = 1 then writeln('Мне 1 год'); if a = 2 then writeln('Мне 2 года'); if a = 3 then writeln('Мне 3 года'); if a = 4 then writeln('Мне 4 года'); if a = 5 then writeln('Мне 5 лет'); if a = 6 then writeln('Мне 6 лет'); if a = 7 then writeln('Мне 7 лет'); if a = 8 then writeln('Мне 8 лет'); if a = 9 then writeln('Мне 9 лет'); if a = 10 then writeln('Мне 10 лет'); if a = 11 then writeln('Мне 11 лет'); if a = 12 then writeln('Мне 12 лет'); if a = 13 then writeln('Мне 13 лет'); if a = 14 then writeln('Мне 14 лет'); if a = 15 then writeln('Мне 15 лет'); if a = 16 then writeln('Мне 16 лет'); if a = 17 then writeln('Мне 17 лет'); if a = 18 then writeln('Мне 18 лет'); if a = 19 then writeln('Мне 19 лет); if a = 20 then writeln('Мне 20 лет'); end;
Эту программу можно было легче через оператор CASE делать) но мы не ищем легких путей
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Составьте программу, которая для целого числа k(от1 до 99) , введеного вами, напечатает фразу "Мне k лет", при этом в нужных случаях слово "лет" заменяя на "год" и "года" В кумире
var a: integer;
begin
writeln ('Введите число От 1 до 20');
readln (a);
if a = 1 then
writeln('Мне 1 год');
if a = 2 then
writeln('Мне 2 года');
if a = 3 then
writeln('Мне 3 года');
if a = 4 then
writeln('Мне 4 года');
if a = 5 then
writeln('Мне 5 лет');
if a = 6 then
writeln('Мне 6 лет');
if a = 7 then
writeln('Мне 7 лет');
if a = 8 then
writeln('Мне 8 лет');
if a = 9 then
writeln('Мне 9 лет');
if a = 10 then
writeln('Мне 10 лет');
if a = 11 then
writeln('Мне 11 лет');
if a = 12 then
writeln('Мне 12 лет');
if a = 13 then
writeln('Мне 13 лет');
if a = 14 then
writeln('Мне 14 лет');
if a = 15 then
writeln('Мне 15 лет');
if a = 16 then
writeln('Мне 16 лет');
if a = 17 then
writeln('Мне 17 лет');
if a = 18 then
writeln('Мне 18 лет');
if a = 19 then
writeln('Мне 19 лет);
if a = 20 then
writeln('Мне 20 лет');
end;
Эту программу можно было легче через оператор CASE делать) но мы не ищем легких путей