sensenagon50
?>

Вася захотел делать на новый год особую гирлянду. В его гирлянде N цветных шариков. Вася хочет запрограммировать работу гирлянды так, чтобы шарики загорались поочередно с определенным шагом К. Так как гирлянда у Васи оброзует кольцо то после N-го шарика счет продолжается спервого шарика напишите в какой последовательности будут загораться шарики на гирлянде у Васи Входные данные: В одной строке даны два натуральных числа N и K не превыщаюшие 100Выходные Выведите N чисел в одной строке через пробел – порядок загорания шариков в гирлянде.​

Информатика

Ответы

misspodvigina
Const maxn=15;
var a: array[1..maxn] of integer;
    skv,prod,gr,i: integer;
begin
  writeln('введите ',maxn,' чисел');
  skv:=0;  prod:=1;
  gr:=0;
  for i:=1 to maxn do
  begin
    write(i,': ');  readln(a[i]);
    if a[i]<0 then skv:=skv+a[i]*a[i];
    if (a[i] mod 2 = 0) and (i mod 2 = 0) then
       prod:=prod*a[i];
    if abs(a[i])>100 then gr:=gr+1;
  end;
  writeln('сумма квадратов отрицательных:  ',skv);
  writeln('произведение четных на четных местах:  ',prod);
  writeln('больше 100 по модулю:  ',gr);
end.

введите 15 чисел
1: 151
2: -231
3: 104
4: 19
5: 36
6: -112
7: 5
8: 8
9: 11
10: 13
11: 45
12: 5
13: 6
14: 17
15: 19
сумма квадратов отрицательных:  65905
произведение четных на четных местах:  -896
больше 100 по модулю:  4

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вася захотел делать на новый год особую гирлянду. В его гирлянде N цветных шариков. Вася хочет запрограммировать работу гирлянды так, чтобы шарики загорались поочередно с определенным шагом К. Так как гирлянда у Васи оброзует кольцо то после N-го шарика счет продолжается спервого шарика напишите в какой последовательности будут загораться шарики на гирлянде у Васи Входные данные: В одной строке даны два натуральных числа N и K не превыщаюшие 100Выходные Выведите N чисел в одной строке через пробел – порядок загорания шариков в гирлянде.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

agafonovalyudmila346
petrosyan35
pisikak999
rakitinat8
Viktorovna
elmira01048775
mstrshulz
bellatrixstudio
orange-salon-job77
kayrina
yuraotradnov
bellenru
Playintim405374
NIKOLAI
grishin