golovins3
?>

Составить программу, используя двумерные массивы: Найти сумму нечетныхцифр строки у которого второй элемент большепервогоPascal)​

Информатика

Ответы

ganul

var

 a: array[,] of integer;

 m, n, i, j, k, sum: integer;

begin

 Write('Введите размер матрицы M и N: '); ReadLn(m, n);

 SetLength(a, m, n);

 randomize;

 k := - 1;

 WriteLn('Массив:');

 for i := 0 to m - 1 do

 begin  

   for j := 0 to n - 1 do

   begin

     a[i, j] := random(100);

     Write(a[i, j]:4);

   end;

   WriteLn;

 end;

 for i := 0 to m - 1 do

    if (a[i, 1] > a[i,0]) and (k = -1) then k := i;

 if k = -1 then

 begin

   WriteLn('Нет строк, у которых второй элемент больше первого');

   exit;

 end;

 for j := 0 to n - 1 do

    if (a[k, j] mod 2 = 1) then sum := sum + a[k, j];

 WriteLn('Сумма нечетных чисел строки, у которой второй элемент больше первого, равна ', sum);

end.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, используя двумерные массивы: Найти сумму нечетныхцифр строки у которого второй элемент большепервогоPascal)​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

donertime8
skachmin
Yelena1409
Merkuloff78
kuzinnv1968
Nikolaevna382
tarasowamash4
tteplovoz3789
Alekseevna
morozov1605
textildlavas21
tanyatanyat
DmitrievnaVera
Ka2ffka141
Vladimirovich1898