var
a: array[,] of integer;
m, n, i, j, max: integer;
begin
Write('Введите размер матрицы M и N: '); ReadLn(m, n);
SetLength(a, m, n);
randomize;
max := - 100;
WriteLn('Массив:');
for i := 0 to m - 1 do
for j := 0 to n - 1 do
a[i, j] := random(200) - 100;
Write(a[i, j]:4);
if (a[i, j] > max) and (j = 2) then max := a[i, j];
end;
WriteLn;
WriteLn('Максимальное число в третьем столбце матрицы равно ', max);
end.
Объяснение:
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу, используя двумерные массивы: Найти максимальное число в третьем столбце матрицы(Pascal)
var
a: array[,] of integer;
m, n, i, j, max: integer;
begin
Write('Введите размер матрицы M и N: '); ReadLn(m, n);
SetLength(a, m, n);
randomize;
max := - 100;
WriteLn('Массив:');
for i := 0 to m - 1 do
begin
for j := 0 to n - 1 do
begin
a[i, j] := random(200) - 100;
Write(a[i, j]:4);
if (a[i, j] > max) and (j = 2) then max := a[i, j];
end;
WriteLn;
end;
WriteLn('Максимальное число в третьем столбце матрицы равно ', max);
end.
Объяснение: