?>
Задание 2. Ученик хотел написать программу рисования римского числа X, но при составлении программы запутался скомандами опустить перо и поднять перо. Исправьте програм-му так, чтобы вместо числа II получилось число Х.использовать Чертежникалгначподнять перосместиться в точку (1, 1)опустить перосместиться на вектор (0, 4)поднять перосместиться на вектор (2, -4)опустить перосместиться на вектор (0, 4)поднять перосместиться на вектор (-2, -4)KOH
Ответы
ответ:1. var
a:array[1..7] of integer;
i:Integer;
begin
//заполнение массива
a[1]:=3;
a[2]:=8;
a[3]:=2;
a[4]:=0;
a[5]:=2;
a[6]:=1;
a[7]:=7;
//вывод массива
for i:=1 to 7 do
Writeln(a[i]);
end.
2. var
c:array[1..12] of integer;
i:Integer;
begin
//заполнение массива
for i:=1 to 12 do
begin
Writeln('Введите ',i,' элемент массива');
readln(c[i]);
end;
//вывод массива
Writeln('Массив');
for i:=1 to 12 do
Write(c[i],' ');
end.
3.var
s:array[1..15] of integer;
i:Integer;
begin
//заполнение массива
for i:=1 to 15 do
s[i]:=random(40);
//вывод массива
Writeln('Массив');
for i:=1 to 15 do
Write(s[i],' ');
end.
4.var
b:array[1..25] of Real;
i:Integer;
begin
//заполнение массива
b[1]:=3;
b[2]:=6;
for i:=3 to 25 do
b[i]:=(b[i-1]+b[i-2])/i;
//вывод массива
Writeln('Массив');
for i:=1 to 25 do
Write(b[i]:9:3);
end.
Объяснение: