var
a, b, c, d, kol: integer;
begin
write('Введите четыре числа A, B, C и D через пробел: ');
readln(a, b, c, d);
if a mod 2 = 0 then inc(kol);
if b mod 2 = 0 then inc(kol);
if c mod 2 = 0 then inc(kol);
if d mod 2 = 0 then inc(kol);
if kol >= 2 then writeln('Среди введенных чисел есть два или более четных числа')
else writeln('Среди введенных чисел менее двух четных');
end.
Объяснение:
Другой вариант (покороче):
a, b, c, d: integer;
if ((a mod 2) + (b mod 2) + (c mod 2) + (d mod 2)) <= 2
then writeln('Среди введенных чисел есть два или более четных числа')
Поделитесь своими знаниями, ответьте на вопрос:
Среди заданных целых чисел A, B, C, D есть хотя бы два четных? Напишите программу на pascal ABC
var
a, b, c, d, kol: integer;
begin
write('Введите четыре числа A, B, C и D через пробел: ');
readln(a, b, c, d);
if a mod 2 = 0 then inc(kol);
if b mod 2 = 0 then inc(kol);
if c mod 2 = 0 then inc(kol);
if d mod 2 = 0 then inc(kol);
if kol >= 2 then writeln('Среди введенных чисел есть два или более четных числа')
else writeln('Среди введенных чисел менее двух четных');
end.
Объяснение:
Другой вариант (покороче):
var
a, b, c, d: integer;
begin
write('Введите четыре числа A, B, C и D через пробел: ');
readln(a, b, c, d);
if ((a mod 2) + (b mod 2) + (c mod 2) + (d mod 2)) <= 2
then writeln('Среди введенных чисел есть два или более четных числа')
else writeln('Среди введенных чисел менее двух четных');
end.