Александровна-Васильевна
?>

С клавиатуры вводится трехзначное число. Написать программу которая определяет какая цифра числа минимальная Напишите в паскале.

Информатика

Ответы

menametov

program z1;

var a,m:integer;

begin

write('Введите трёхзначное число: ');

readln(a);

m:=a mod 10;

if a div 100 < m then m:=a div 100;

if a div 10 mod 10 < m then m:=a div 10 mod 10;

write('Минимальная цифра числа: ',m)

end.

Объяснение:

div - результат целочисленного деления

mod - остаток от целочисленного деления  

Вводим число

Присваиваем переменной m значение последней цифры числа

Сравниваем переменную m  с первой цифрой числа, если первая цифра числа меньше переменной m, то присваиваем переменной m значение первой цифры числа

Сравниваем переменную m  со второй цифрой числа, если вторая цифра числа меньше переменной m, то присваиваем переменной m значение второй цифры числа

Выводим переменную m

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

С клавиатуры вводится трехзначное число. Написать программу которая определяет какая цифра числа минимальная Напишите в паскале.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vladimir686
AleksandrIvanovich1273
aggeeva
puchkovajulia
sanyaborisov910067
olesya-cat8601
maroseyka
alexderru
JisesLove19955
karien87
dawlatowajana
Bobkov
Reutskii-Kirilovskii1625
Макаров1887
ekrosenergoserv