var a,b,i,c,l:integer;
procedure F(n:integer);
begin
a:=a*n;
end;
c:=0;
a:=1;
write('Введите количество аргументов: '); readln(l);
for i:=1 to l do begin
F(i);
c:=c+a;
write(c);
end.
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу вычисления выражения: s =1!+2!+3!+...+ н! Используйте ПРОЦЕДУРУ вычисления факториала!
var a,b,i,c,l:integer;
procedure F(n:integer);
begin
a:=a*n;
end;
begin
c:=0;
a:=1;
write('Введите количество аргументов: '); readln(l);
for i:=1 to l do begin
F(i);
c:=c+a;
end;
write(c);
end.