aleksagrbec39
?>

Дан массив a из n целых чисел — информация о количестве осадков, выпавших за каждый из n дней. Требуется определить, в какие дни осадков не было. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве. На следующей строке через пробел записаны целые числа ai (0≤ai≤103) — количество осадков в i-й день. Формат выходных данных Требуется в одной строке через пробел вывести номера дней, в которые осадков не было. входные данные 4 100 20 0 318 10 0 0 0 0 0 47 777 66 89 6 выходные данные 3 1 2 3 4 5

Информатика

Ответы

anitanemtsewa

#include <sstream>

#include <iostream>

int main()

{

size_t n;

std::cin >> n;

std::ostringstream out;

for (size_t i = 0; i < n; ++i)

{

static short a;

std::cin >> a;

if (a <= 0) out << (i + 1) << ' ';

}

std::cout<<out.str();

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дан массив a из n целых чисел — информация о количестве осадков, выпавших за каждый из n дней. Требуется определить, в какие дни осадков не было. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве. На следующей строке через пробел записаны целые числа ai (0≤ai≤103) — количество осадков в i-й день. Формат выходных данных Требуется в одной строке через пробел вывести номера дней, в которые осадков не было. входные данные 4 100 20 0 318 10 0 0 0 0 0 47 777 66 89 6 выходные данные 3 1 2 3 4 5
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ooo-krasa
ruslanriad10
kampina1
jim2k
catmos
Sergeevich-Novikov
tigran87-87
КириллЕгорова1906
Dushko
deniskotvitsky56
nagas
tiv67
Vetroff-11
Bordo
mirsanm26249