saa002
?>

напишите пропоследовательности грамму которая в натуральных чисел определяет максимальное число оканчивающееся на 8. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности имеется число, которое оканчивающееся на 8. Количество чисел не превышает 1000. введённые числа не превышают 30 000. Программа должна вывести ожно число-максимальное число, оканчивающееся на 8

Информатика

Ответы

михаил

#include <iostream>

using namespace std;

signed main(){

   int n, mx = -1;

   cin >> n;

   while(n--){

       int x;

       cin >> x;

       if(x % 10 == 8)

           mx = max(mx, x);

   }

   cout << mx;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

напишите пропоследовательности грамму которая в натуральных чисел определяет максимальное число оканчивающееся на 8. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности имеется число, которое оканчивающееся на 8. Количество чисел не превышает 1000. введённые числа не превышают 30 000. Программа должна вывести ожно число-максимальное число, оканчивающееся на 8
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

moidela87
akakne86
Fedorov1283
Pautova1119
anna241273
annayarikova
Panei
mstrshulz
Сумарокова
Tatianamir765654
D.Yu. Polina1703
rusmoney92
natakrechko
vlebedeva81
Серопян