Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу, которая запрашивает у пользователя число. Если число больше нуля, то вывести на экран сообщение «Тепло». Если введенное число меньше нуля, то вывести сообщение на экран «Холодно»на языке python)
===== С++ 17 =====
#include <iostream>
using namespace std;
void swap(int &a, int &b)
{
int t = a;
a = b;
b = t;
}
int main()
{
int n;
cin >> n;
int a[n];
srand(time(NULL));
for(int i = 0; i < n; i++)
{
a[i] = rand() % 198 - 99;
cout << a[i] << " ";
}
cout << endl;
bool perm = false;
int j;
for(int i = 0; i < n - 1; i++)
{
if(a[i] > a[i + 1])
{
swap(a[i], a[i + 1]);
j = i;
perm = true;
while(perm && (j > 0))
if(a[j] < a[j - 1])
{
perm = true;
swap(a[j], a[j - 1]);
j--;
}
else perm = false;
}
}
for(int i = 0; i < n; i++)
cout << a[i] << " ";
cout << endl;
return 0;
}