inj-anastasia8
?>

если можно то всё и в хорошем виде так же паскаль и как можно скорее Для N чисел, заданных случайным образом [-19;21], подсчитать сумму и количество чисел, кратных 3. Значение N ввести с клавиатуры. 1. Построить знаковую модель. 2. Составить блок-схему алгоритма. 3. Написать программу.

Информатика

Ответы

bogatskayaa

#include <iostream>

using namespace std;

int main(){

int number = 0;

cout << "Enter the month number: ";

cin >> number;

if ((number >= 1) and (number <= 12)){

 if (number < 8){

  if (number % 2 != 0){

   cout << "31 days";

  }else if((number % 2 == 0) and (number != 2)){

   cout << "30 days";

  }else if(number == 2){

   cout << "28 days";

  }

 }else if (number > 7){

 if (number % 2 != 0){

  cout << "30 days";

 }else if(number % 2 == 0){

  cout << "31 days";

  }

 }

}else{

 cout << "Please enter a valid number";

}

return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

если можно то всё и в хорошем виде так же паскаль и как можно скорее Для N чисел, заданных случайным образом [-19;21], подсчитать сумму и количество чисел, кратных 3. Значение N ввести с клавиатуры. 1. Построить знаковую модель. 2. Составить блок-схему алгоритма. 3. Написать программу.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Давид-Александр
sergeykvik13
mar1030
al2nik2ol
Vasilisan
dnikolay365
Strelkov567
chaa140
Евгеньевич-Куликов1614
volodin-alexander
Людмила902
Dato24043846
Bondarev_Ayupova795
Сергеевич1907
sbelova