aerendzhenova5
?>

Задача приведена на фото, программу написать полностью, как положено. * за неправильные тупые ответы - бан!​

Информатика

Ответы

kuhonka2021

Самое маленькое по размеру.

Если яблоко в руке больше, чем на столе то:

Положить яблоко во вторую корзину

Если меньше, то:

Оставить его на столе, а во вторую корзину положить предыдущее яблоко, которое лежало на столе.

Даны два массива, в одном - случайные числа, второй такого же размера, как и первый, но не содержит элементов.

Найти в первом массиве самый маленький элемент и присвоить переменной min - этот элемент. Все остальные - переместить во второй массив.

Программа:

var basket1, basket2:array[0..10] of integer;  

min, i: integer;

begin

 // Переменные по умолчанию 0, в таком случае не можем быть минимального числа.  

 // Но я знаю, что в массиве, максимальное число = 100. Возьмём его за минимальное - для сравнения.

 min := 101;  

 

 // Заполняем первый массив случайными числами. От 0 до 100.  

 for i:=0 to 10 do

   begin

     basket1[i] := random(100);  

     basket2[i] := 0;

     write(basket1[i]:3);  

   end;  

   

 writeln();

 

 for i:=0 to 10 do

   if basket1[i] < min then

     begin

       basket2[i] := min;

       min := basket1[i];  

     end

   else

     basket2[i] := basket1[i];

   

 writeln(min);

 

end.

Объяснение:

Здесь не надо писать программу. Я очень сомневаюсь, что в 9 классе нужно будет написать программу под это задание.

Строки которые начинаются с // - являются комментариями, их можно удалить.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задача приведена на фото, программу написать полностью, как положено. * за неправильные тупые ответы - бан!​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

svetarakityanskaya
Ofelya1308
merzlikinairena
shilinmikhaillg
marinakmaa86
Chuhnin195107364
ASRodichev
menesmir
Ignateva737
Bogataya Vladimir318
ПетровичЖивотовская1245
ganzashop
Gennadievna bessonov
gumirovane2294
Акимцева27