Мартынова1638
?>

Написать программу, вычисляющую значение y, если значение x вводится с клавиатуры. Результат выдать на экран​

Информатика

Ответы

pechinin
// PascalABC.Net 3.0, сборка 1076
var
  s,ss:string;
  i,n,p:integer;
begin
  Write('Введите строку: '); Readln(s);
  n:=Length(s); p:=Pos(',',s);
  if p in [1..n-1] then begin
    ss:=Copy(s,p+1,n-p);
    n:=Length(ss); p:=Pos(',',ss);
    if p=0 then Writeln(ss)
    else Writeln(Copy(ss,1,p-1))
    end
  else Writeln('*** Нечего выводить ***')
end.
     
Тестовые решения:
Введите строку: 01234,45679,1011213,14151617
45679

Введите строку: 01234,45679101121314151617
45679101121314151617

Введите строку: 01234,
*** Нечего выводить ***

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, вычисляющую значение y, если значение x вводится с клавиатуры. Результат выдать на экран​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Narine natalya
Femida76
Natalya1895
Mikhailovna1444
trubchaninova71511
Svetlana191
Бражинскене_Алексей
kuharhuks
sergeev-alp5
ribanina
Борисовна_Дмитриевич1003
elena-ppk
cheshirsky-kot
krisrespect
▲