Составьте программу, определяющую является ли введённое пользователем трехзначное число "перевёртышом", т.е. числом, десятичная запись которого читается одинаково слева направо и справа налево. На языке PYTHON
Var i:integer; s:string; f:Text; begin Assign(f,'input.txt'); Reset(f); while not Eof(f) do begin Readln(f,s); Writeln(s,' *** символов: ',Length(s)) end; Close(f) end.
Тестовое решение: Буря мглою небо кроет, *** символов: 22 Вихри снежные крутя; *** символов: 20 То, как зверь, она завоет, *** символов: 26 То заплачет, как дитя, *** символов: 22 То по кровле обветшалой *** символов: 23 Вдруг соломой зашумит, *** символов: 22 То, как путник запоздалый, *** символов: 26 К нам в окошко застучит *** символов: 23
i:integer;
s:string;
f:Text;
begin
Assign(f,'input.txt'); Reset(f);
while not Eof(f) do begin
Readln(f,s);
Writeln(s,' *** символов: ',Length(s))
end;
Close(f)
end.
Тестовое решение:
Буря мглою небо кроет, *** символов: 22
Вихри снежные крутя; *** символов: 20
То, как зверь, она завоет, *** символов: 26
То заплачет, как дитя, *** символов: 22
То по кровле обветшалой *** символов: 23
Вдруг соломой зашумит, *** символов: 22
То, как путник запоздалый, *** символов: 26
К нам в окошко застучит *** символов: 23