1. Даны высота треугольника h и площадь S. Вычислить сторону треугольника.
var h,S:integer; a:real; begin writeln(“Input h and S”); readln(h,S); a:=S/h*2; writeln(“a = “,a); end. 2. На вход программы подается число, отличное от 0. Определить положительное оно или отрицательное.
var a:integer; begin writeln(“Input a”); readln(a); if a>0 writeln(“Positive”) else writeln(“Negative”); end. 3. На вход программы подается число n. Вывести значения степеней 2 от 1 до n.
var n,i,c:integer; begin writeln(“Input n”); readln(n); c:=1; For i:=1 to n do begin c:=c*2; writeln(c); end; end. 4. На вход программы подается число. Вывести его факториал.
var a,n:integer; begin writeln(“Input a”); readln(a); n:=1; while a<>1 do begin n:=n*a; a:=a-1; end; writeln(n); end. 5. На вход программы подается число, отличное от 0. Определить сумму цифр в числе.
var a,s:integer; begin writeln(“Input a”); readln(a); s:=0; repeat begin s:=s+(a mod 10); a:=a div 10; end; until a=0; writeln(s); end.
var h,S:integer;
a:real;
begin
writeln(“Input h and S”);
readln(h,S);
a:=S/h*2;
writeln(“a = “,a);
end.
2. На вход программы подается число, отличное от 0. Определить положительное оно или отрицательное.
var a:integer;
begin
writeln(“Input a”);
readln(a);
if a>0
writeln(“Positive”)
else
writeln(“Negative”);
end.
3. На вход программы подается число n. Вывести значения степеней 2 от 1 до n.
var n,i,c:integer;
begin
writeln(“Input n”);
readln(n);
c:=1;
For i:=1 to n do
begin
c:=c*2;
writeln(c);
end;
end.
4. На вход программы подается число. Вывести его факториал.
var a,n:integer;
begin
writeln(“Input a”);
readln(a);
n:=1;
while a<>1 do
begin
n:=n*a;
a:=a-1;
end;
writeln(n);
end.
5. На вход программы подается число, отличное от 0. Определить сумму цифр в числе.
var a,s:integer;
begin
writeln(“Input a”);
readln(a);
s:=0;
repeat
begin
s:=s+(a mod 10);
a:=a div 10;
end;
until a=0;
writeln(s);
end.