?>
1) Составить программу, которая запрашивает целое трёхзначное число и на экран выдаёт остаток от деления этого числа на 100. 2) Напишите программу нахождения минимального и максимального из 3-х чисел, введённых с клавиатуры. 3) Вычислить среднее арифметическое 3-х чисел, введенных с клавиатуры 4) Журавлики Петя, Катя и Сережа делают из бумаги журавликов. Вместе они сделали S журавликов. Сколько журавликов сделал каждый ребенок, если известно, что Петя и Сережа сделали одинаковое количество журавликов, а Катя сделала в два раза больше журавликов, чем Петя и Сережа вместе? Программа запрашивает одно натуральное число S – общее количество сделанных журавликов. Нужно вывести три числа, разделенных пробелами – количество журавликов, которые сделал каждый ребенок (Петя, Катя и Сережа Примеры № Ввод Вывод 1 6 1 4 1 2 24 4 16 4 3 60 10 40 10
Ответы
const
n=5;
m=5;
var
a:array [1..n,1..m] of integer;
i,j,k,t:integer;
begin
writeln('Исходная матрица:');
for i:=1 to n do
begin
for j:=1 to m do
begin
a[i,j]:=random(8)-4;
write(a[i,j]:2,' ')
end;
writeln
end;
for i:=1 to n do
for j:=1 to m-1 do
for k:=j+1 to m do
if a[i,j]>a[i,k] then
begin
t:=a[i,j];
a[i,j]:=a[i,k];
a[i,k]:=t
end;
writeln('Полученная матрица:');
for i:=1 to n do
begin
for j:=1 to m do
write(a[i,j]:2,' ');
writeln
end;
end.