ev27076878
?>

Составьте программу вычисления значения функции  у=х2- х2-+16х-43 для х, меняющегося в диапазоне от 4 до -4 с шагом 0, 5 Пишите на Python ​

Информатика

Ответы

LYuBOV
//Pascal ABC.NET v3.1 сборка 1219

Const
 n=5;

Var
 ar:array[1..n] of integer;
 i,j,k:integer;
begin
 randomize;
 writeln('First array:');
 for i:=1 to n do
  begin
   ar[i]:=random(-3,3);
   write(ar[i]:4);
  end;
 for i:=1 to n-1 do {ммм, пузырёк. Но за быструю сортировку здесь репортят}
  for j:=i+1 to n do
   if ar[i]>ar[j] then
    begin
     k:=ar[i];
     ar[i]:=ar[j];
     ar[j]:=k;
    end;
 writeln;
 writeln('Sorted array:');
 for i:=1 to n do
 write(ar[i]:4);
 writeln;
 for i:=1 to n do
 if ar[i]=0 then
  begin
   write('Index of 0 is ',i);
   break;
  end;
end.

Пример работы программы:
First array:
  -2  -3   0  -3   3
Sorted array:
  -3  -3  -2   0   3
Index of 0 is 4

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу вычисления значения функции  у=х2- х2-+16х-43 для х, меняющегося в диапазоне от 4 до -4 с шагом 0, 5 Пишите на Python ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ivanovmk1977
Карен
abrolchik8511
ecogoi
ganorussia
Alyona
uttgroup
PivovarovaIlina1437
abuley
langprint
UvarovAndrei
grafffmc
igor8809337
Эдгеева219
Чунихина1586