cheremetdiana
?>

Язык кода Python. Игра «Компьютер угадывает число» Поменяйте мальчика и компьютер из задачи местами. Теперь мальчик загадывает число между 1 и 100 (включительно Компьютер может спросить у мальчика: «Твое число равно, меньше или больше, чем число N?», где N — число, которое хочет проверить компьютер. Мальчик отвечает одним из трёх чисел: 1 — равно, 2 — больше, 3 — меньше. Напишите программу, которая с цепочки таких вопросов и ответов мальчика угадывает число. Дополнительно: сделайте так, чтобы можно было гарантированно угадать число за семь попыток.

Информатика

Ответы

Anatolevich667

import random

right_ans = int(input('Введите число от 1 до 100: '))

a = 1

b = 101

right = False

tries = 1

while not right:

 comp_answer = random.randint(a, b)

 if comp_answer > right_ans:

   b = comp_answer

 elif comp_answer < right_ans:

   a = comp_answer + 1

 else:

   print(f'Yes, thats it, computer guessed with {tries} attempts')  

   right = True

 tries += 1

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Язык кода Python. Игра «Компьютер угадывает число» Поменяйте мальчика и компьютер из задачи местами. Теперь мальчик загадывает число между 1 и 100 (включительно Компьютер может спросить у мальчика: «Твое число равно, меньше или больше, чем число N?», где N — число, которое хочет проверить компьютер. Мальчик отвечает одним из трёх чисел: 1 — равно, 2 — больше, 3 — меньше. Напишите программу, которая с цепочки таких вопросов и ответов мальчика угадывает число. Дополнительно: сделайте так, чтобы можно было гарантированно угадать число за семь попыток.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Nikita
tsatskina857
Потапова 79275136869323
Заполните пропуски и постройте
gbg231940
prianik6
Eduard Popik
expo3217
shabaev19542355
Yelena_Yuliya1847
Шарабанов
sargisyan
Svetlana1884
Oksana-Kirakosyan1301
Кононова-БЕСКРОВНАЯ
bikemaster
▲