info2990
?>

Язык Pascal. Напишите программу, которая позволяет вводить дату в "американском" формате-мм/дд/гг, - и преобразовывает её в формат дд.мм.гг. ​

Информатика

Ответы

valerii_Georgievna915
#include <stdio.h>

int main(void) {
 int a1,a2,b,k1=0,k2=0;
 printf("a1 = ");
 scanf("%d",&a1);
 printf("a2 = ");
 scanf("%d",&a2);
 if (a1>0) b=a1; else b=-a1;
 while (b>0) {
  k1++; b /= 10;
 }
 if (a2>0) b=a2; else b=-a2;
 while (b>0) {
  k2++; b /= 10;
 }
 if (k1>k2) printf("В числе %d больше цифр, чем в числе %d",a1,a2);
 else if (k2>k1) printf("В числе %d больше цифр, чем в числе %d",a2,a1);
  else printf("Количество цифр в числах одинаково");
 return 0;
}

Пример:
a1 = 153
a2 = -4680
В числе -4680 больше цифр, чем в числе 153

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Язык Pascal. Напишите программу, которая позволяет вводить дату в "американском" формате-мм/дд/гг, - и преобразовывает её в формат дд.мм.гг. ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Mariya-Karaseva
Pautova1119
Obukhov-Buriko
yakovlevasvetlanalvovna209
emilmishin1032
mrvasilev2012
es196
О. Карпов1691
Gor Anatolevich
ekaterinasamoylova4705
suny84
madjk
КристинаАлександр
Григорьевич915
Boykoyelena