Поделитесь своими знаниями, ответьте на вопрос:
Задание 1 ( Написать программу на Паскале. Даны два действительных числа x и y. Вычислить их удвоенную сумму, разность, произведение и частное. Задание 2 ( ). Составить программу на Паскале, которая запросит два вещественных числа и три целых. Задание 3 ( ). Написать программу на Паскале для решения задачи. На рисунке изображены параллельные прямые a и b, расстояние между которыми равно 4. Точки A и B принадлежат прямой a, а точки C и D — прямой b. Найти площадь трапеции ABCD, если AB=3, CD=6. На проверку нужно прислать коды программ и результаты их работы в виде скриншотов окна программы.
#include <stdio.h>
#include <stdlib.h>
#include <time.h>
#define n 10
int main()
{
srand(time(NULL));
int arr[n];
int tmp;
/*Заполняем массив случайными числами и выводим на экран*/
for (int i = 0; i < n;i++)
{
arr[i] = rand() % 10;
printf("%i ", arr[i]);
}
/*Сортировка*/
for (int i = 0; i < n; i++) {
if (i % 2 == 0)
for (int j = 2; j < n; j += 2) {
if (arr[j] < arr[j - 1]) {
tmp = arr[j];
arr[j] = arr[j - 1];
arr[j - 1] = tmp;
}
}
else
for (int j = 1; j < n; j += 2) {
if (arr[j] < arr[j - 1]) {
tmp = arr[j];
arr[j] = arr[j - 1];
arr[j - 1] = tmp;
}
}
}
/*Вывод отсортированного массива на экран*/
printf("\n");
for (int i = 0; i < 10; i++)
{
printf("%i ", arr[i]);
}
return 0;
}