Taniagrachev
?>

В задаче необходимо было найти значение следующего выражения относительно переменных a и b: 4(a2−5b)2 Пример 1: 1 2 Вывод 1: 324 Пример 2: 4 -3 Вывод 2: 3844 В этой программе забыли поставить скобки в нужных местах и допустили ещё одну грубую ошибку. Из-за этого программа работает неправильно. Найдите и исправьте ошибки в тексте программы. Var a, b, c: integer; begin readln(a, b); c:=4 * a*a - 5*b * 4 * a*a - 5*b; writeln(c); end.

Информатика

Ответы

Natakarpova75732
                                     PascalABC.NET                                       beginvar n := ReadInteger('Введите количество резисторов:');var Rs := ReadArrInteger('Введите их сопротивления:',n);Writeln(NewLine, 'Общее сопротивление цепи равно:');Println(' при последовательном соединении -', Rs.Sum,'Ом');Println(' при параллельном соединении -', 1/Rs.Sum(r->1/r),'Ом');end.

или кратко:

beginvar Rs := ReadArrInteger(3);Println('послед:', Rs.Sum);Println('парал:', 1/Rs.Sum(r->1/r));end.

Пример работы:


решите нужно очень (составить программу определения общего сопротивления электрической цепи при посл
решите нужно очень (составить программу определения общего сопротивления электрической цепи при посл

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

В задаче необходимо было найти значение следующего выражения относительно переменных a и b: 4(a2−5b)2 Пример 1: 1 2 Вывод 1: 324 Пример 2: 4 -3 Вывод 2: 3844 В этой программе забыли поставить скобки в нужных местах и допустили ещё одну грубую ошибку. Из-за этого программа работает неправильно. Найдите и исправьте ошибки в тексте программы. Var a, b, c: integer; begin readln(a, b); c:=4 * a*a - 5*b * 4 * a*a - 5*b; writeln(c); end.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Olgachalova111
drozd228758
Васильева-Александрович
mbykovskiy
alesia1986
Akvamontaz
Анна1169
Виктория Нина
innaglobal21
Константин
irinalav2705745
aninepp
likakedo4ka439
Olybetezina1973
bogatskayaa