Olga_Vyacheslavovich1054
?>

1.В консоли мы можем рисовать с различных символов. Ваша задача нарисовать на экране квадрат из символов ‘*’ размером 10X10...Делать в питоне 2. Написать программу, которая с цикла создаст строку из чисел Фибоначчи и выведет ее на экран. (Числа Фибоначчи - это ряд чисел, где каждое число является суммой двух предыдущих) Вывод в строку надо закончить, когда текущее число станет больше 100 Делать в питоне

Информатика

Ответы

ГусенковФролова1121
1. Вот так это пишется с функцией

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
function IsPrime(n:integer):boolean;
begin
  if n<4 then Result:=True
  else begin
    var found:= (n mod 2 = 0);
    var p:=3;
    while (not found) and (sqr(p)<=n) do
      begin
      found:=(n mod p = 0);
      p+=2
      end;
    Result:=not found
    end
end;

begin
  Writeln('k=',ArrRandom(ReadInteger('n='),1,999).Println.
    Where(x->IsPrime(x)).Count)
end.

Тестовое решение:
n= 10
401 828 780 444 694 965 23 341 673 875
k=3

2. А вот так это пишется с процедурой

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
procedure IsPrime(n:integer; var res:boolean);
begin
  if n<4 then res:=True
  else begin
    var found:= (n mod 2 = 0);
    var p:=3;
    while (not found) and (sqr(p)<=n) do
      begin
      found:=(n mod p = 0);
      p+=2
      end;
    res:=not found
    end
end;

begin
  var a:=ArrRandom(ReadInteger('n='),1,999); a.Println;
  var k:=0;
  var prime:boolean;
  foreach var e in a do begin
    IsPrime(e,prime);
    if Prime then Inc(k)
    end;
  Writeln('k=',k)
end.

Тестовое решение:
n= 12
199 43 71 365 417 904 170 212 694 103 161 689
k=4

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1.В консоли мы можем рисовать с различных символов. Ваша задача нарисовать на экране квадрат из символов ‘*’ размером 10X10...Делать в питоне 2. Написать программу, которая с цикла создаст строку из чисел Фибоначчи и выведет ее на экран. (Числа Фибоначчи - это ряд чисел, где каждое число является суммой двух предыдущих) Вывод в строку надо закончить, когда текущее число станет больше 100 Делать в питоне
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

catsk8
kim-1971
Оксана170
Shitikov-M.A.1307
appmicom
Valentinovna
natalia-bokareva
gub191025
motor2218
shoora
козлов
radatailless
chavagorin
lakeeva90
Некрасов Валентина1097