?>
решить задачу на питоне. Задача На прямой дощечке вбиты гвоздики. Любые два гвоздика можно соединить ниточкой. Требуется соединить какие-то пары гвоздиков ниточками так, чтобы к каждому гвоздику была привязана хотя бы одна ниточка, а суммарная длина всех ниточек была минимальна. Входные данные: - в первой строке записано число N - количество гвоздиков (2<=N<=100); - в следующей строке записано N чисел - координаты всех гвоздиков (неотрицательные целые числа, не превосходящие 10000 Выходные данные: выведите единственное число - минимальную суммарную длину всех ниточек. Примеры № Входные данные Выходные данные 1 5 4 10 0 12 2 6
Ответы
// Внимание! Если программа не работает, обновите версию!
Нулевой шаг: создание типизированного файла нужной структуры
begin
var f:file of real;
Assign(f,'MyReal.bin'); Rewrite(f);
loop 2 do begin
SeqRandomInteger(10,1,100).Select(t->t/10).ForEach(t->Write(f,t));
SeqRandomInteger(10,-100,-1).Select(t->t/10).ForEach(t->Write(f,t));
end;
f.Seek(0); // начало файла
var b:real;
while not Eof(f) do begin Read(f,b); Print(b) end;
Println;
f.Close
end.
Пример:
9.7 1 4.1 8.3 5.6 9.3 2.2 9.3 5.8 8.8 -8.8 -7.7 -1.4 -5.2 -7.2 -8.3 -1.3 -8.9 -6.3 -4.8 3.5 3.8 3.2 6 3.2 4.5 10 4.5 6.1 0.7 -8 -0.8 -3.3 -9.5 -7.9 -0.9 -7.4 -9.4 -1.8 -4.6
Собственно, программа
begin
var f1,f2:file of real;
Assign(f1,'MyReal.bin'); Reset(f1);
if f1.FileSize mod 20<>0 then begin
Writeln('Количество компонент во входном файле не кратно 20');
Exit
end;
Assign(f2,'MyReal2.bin'); Rewrite(f2);
var buf:=new real[5];
var b:real;
while not Eof(f1) do begin
// переписываем пять положительных
loop 5 do begin Read(f1,b); Write(f2,b) end;
// считываем пять положительных в буфер
for var i:=0 to 4 do Read(f1,buf[i]);
// переписываем пять отрицательных
loop 5 do begin Read(f1,b); Write(f2,b) end;
// пишем пять положительных из буфера
foreach var t in buf do Write(f2,t);
// переписываем пять отрицательных
loop 5 do begin Read(f1,b); Write(f2,b) end
end;
f1.Close;
// контрольное чтение
f2.Seek(0); // к началу
while not Eof(f2) do begin Read(f2,b); Print(b) end;
Writeln;
f2.Close
end.
Пример
9.7 1 4.1 8.3 5.6 -8.8 -7.7 -1.4 -5.2 -7.2 9.3 2.2 9.3 5.8 8.8 -8.3 -1.3 -8.9 -6.3 -4.8 3.5 3.8 3.2 6 3.2 -8 -0.8 -3.3 -9.5 -7.9 4.5 10 4.5 6.1 0.7 -0.9 -7.4 -9.4 -1.8 -4.6