Neveselova
?>

Pascal Ниже записан алгоритм. Сколько существует таких чисел `x`, при вводе которых алгоритм печатает сначала `6`, а потом `27`? Что делает данная программа? Какие это числа? Объясните свои ответы. var x, a, b: longint; begin readln(x); a:=0; b:=1; while x>0 do begin a:=a + 1; if a mod 2 =0 then b:=b*(x mod 10); x:=x div 10; end; writeln(a); write(b); end.

Информатика

Ответы

denisdenisov63

а не проще на типе интеджер

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Pascal Ниже записан алгоритм. Сколько существует таких чисел `x`, при вводе которых алгоритм печатает сначала `6`, а потом `27`? Что делает данная программа? Какие это числа? Объясните свои ответы. var x, a, b: longint; begin readln(x); a:=0; b:=1; while x>0 do begin a:=a + 1; if a mod 2 =0 then b:=b*(x mod 10); x:=x div 10; end; writeln(a); write(b); end.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

morozovalexander90
Designer
yaudo47
BelozerovaGeller648
verachus
Татьяна Марина1287
adman7
VdoffOlga
artmasterstyle
Середа-Сергеенков980
Kelena190533
Шеина
Ivanovich-A.V
petr2077
nadyatsoi